Unable to claim MINE rewards from Pool 3

I have been trying to claim my MINE rewards on the Pylon Gateway for 2 days now and it just re directs me to a blank white screen. The transaction does not broadcast to the terra network. I have tried the following on multiple devices and platforms including the mobile app.

  1. Disconnect Terra Wallet and re connect.
  2. Use a different device (I have used 3 devices in total)
  3. Delete browsing history and attempt again.
    None of these seem to work.
    It is quite concerning as there seems to be no response from any devs or support for this issue.
    Screenshot (74)

I got exactly the same issue.
Checked different browsers, reconnected and reinstalled terra station.
Seems to be web interface fault.

I got high hopes for this project, but this is not the first bug I’ve encountered here …

You can get more support on reddit than here :(.

1 Like

Thanks for the response. I tried re-installing my terra extension and chrome but the issue still persists. It seems like every week there are new bugs with Pylon.

bump…same issue as OP!

1 Like

I am experiencing the same issue. Tried clearing browing history and restarted Chrome / PC, and the problem still persists. Blank screen when trying to claim MINE from Pool 3.

1 Like

Hi everyone,

I have also posted on Reddit, there are some people who are trying to help over there.
The issue seems to be an error/partial with the Terra network. I’ll post the link for the Reddit post. See below for the link.